Asbc cs 最长非降子序列子序列是多少?

通信术语bccs是什么意思?ps:不是bcc、bbcc
通信术语bccs是什么意思?ps:不是bcc、bbcc
09-08-28 &
BCCS Bergen Center for Computational Science (University of Bergen, Norway)BCCS Board of Commissioners of Currency, SingaporeBCCS Bare Copper Covered SteelBCCS Bristol Centre for Complexity Sciences (University of B UK)BCCS Butler Cave Conservation Society (Williamsville VA)BCCS Baltimore Credit & Collection ServicesBCCS Bucks County Choral Society (Doylestown, PA)BCCS Beaver County Christian School (Beaver Falls, PA)BCCS Battlefield Command and Control SystemBCCS Business Community Cluster Services (Novell)BCCS British Columbia Cancer SocietyBCCS Back-Up COP Correlation Site (GCCS)BCCS Brigade Command and Control SystemBCCS Burnaby Children's Centres Society (Burnaby, British Columbia, Canada)
请登录后再发表评论!nlogn的最长上升子序列(pascal语言)_百度文库
两大类热门资源免费畅读
续费一年阅读会员,立省24元!
nlogn的最长上升子序列(pascal语言)
上传于|0|0|文档简介
&&nlogn的最长上升子序列(pascal语言)
阅读已结束,如果下载本文需要使用0下载券
想免费下载更多文档?
定制HR最喜欢的简历
你可能喜欢BCCS的海词问答与网友补充:
相关词典网站:POJ 1887-Testing the CATCHER(dp_最长下降子序列)-爱编程
POJ 1887-Testing the CATCHER(dp_最长下降子序列)
Testing the CATCHER
Time Limit:&1000MS
Memory Limit:&30000K
Total Submissions:&15382
Accepted:&5657
Description
A military contractor for the Department of Defense has just completed a series of preliminary tests for a new defensive missile called the CATCHER which is capable of intercepting multiple incoming offensive missiles. The CATCHER is supposed to be a remarkable
defensive missile. It can move forward, laterally, and downward at very fast speeds, and it can intercept an offensive missile without being damaged. But it does have one major flaw. Although it can be fired to reach any initial elevation, it has no power
to move higher than the last missile that it has intercepted.&
The tests which the contractor completed were computer simulations of battlefield and hostile attack conditions. Since they were only preliminary, the simulations tested only the CATCHER's vertical movement capability. In each simulation, the CATCHER was fired
at a sequence of offensive missiles which were incoming at fixed time intervals. The only information available to the CATCHER for each incoming missile was its height at the point it could be intercepted and where it appeared in the sequence of missiles.
Each incoming missile for a test run is represented in the sequence only once.&
The result of each test is reported as the sequence of incoming missiles and the total number of those missiles that are intercepted by the CATCHER in that test.&
The General Accounting Office wants to be sure that the simulation test results submitted by the military contractor are attainable, given the constraints of the CATCHER. You must write a program that takes input data representing the pattern of incoming missiles
for several different tests and outputs the maximum numbers of missiles that the CATCHER can intercept for those tests. For any incoming missile in a test, the CATCHER is able to intercept it if and only if it satisfies one of these two conditions:&
The incoming missile is the first missile to be intercepted in this test.&
The missile was fired after the last missile that was intercepted and it is not higher than the last missile which was intercepted.
The input data for any test consists of a sequence of one or more non-negative integers, all of which are less than or equal to 32,767, representing the heights of the incoming missiles (the test pattern). The last number in each sequence is -1, which signifies
the end of data for that particular test and is not considered to represent a missile height. The end of data for the entire input is the number -1 as the f it is not considered to be a separate test.
Output for each test consists of a test number (Test #1, Test #2, etc.) and the maximum number of incoming missiles that the CATCHER could possibly intercept for the test. That maximum number appears after an identifying message. There must be at least one
blank line between output for successive data sets.&
Note: The number of missiles for any given test is not limited. If your solution is based on an inefficient algorithm, it may not execute in the allotted time.&
Sample Input
Sample Output
maximum possible interceptions: 6
maximum possible interceptions: 2
题意:让求最长的下降非排序子序列。
思路:dp存储当前的最优步数。没用优化算法,直接硬求。
#include &stdio.h&
#include &string.h&
#include &stdlib.h&
#include &iostream&
#include &algorithm&
#include &map&
#include &string&
const int inf=0x3f3f3f3f;
int a[40010];
int dp[40010];
int main()
int n,i,j;
scanf(&%d&,&n);
if (n==-1)
scanf(&%d&,&n);
if (n==-1)
a[++cnt]=n;
int maxx=0;
for (i=1;i&=i++)
for (j=1;j&=i-1;j++)
if (a[i]&a[j]&&dp[i]&dp[j]+1)
dp[i]=dp[j]+1;
if (dp[i] & maxx) maxx = dp[i];
printf(&Test #%d:\n&,t++);
maximum possible interceptions: %d\n\n&,maxx);
版权所有 爱编程 (C) Copyright 2012. . All Rights Reserved.
闽ICP备号-3
微信扫一扫关注爱编程,每天为您推送一篇经典技术文章。}

我要回帖

更多关于 最长公共子序列 的文章

更多推荐

版权声明:文章内容来源于网络,版权归原作者所有,如有侵权请点击这里与我们联系,我们将及时删除。

点击添加站长微信