whac a mole 左下角锤子怎么用。点了但是好像没效果呢,直接就进入tdcooldownn了。

POJ 3034 Whac-a-Mole
Whac-a-Mole
Time Limit: 2000MS&& Memory Limit: 65536K
Total Submissions: 2993&& Accepted: 904
Description
While visiting a traveling fun fair you suddenly have an urge to break the high score in the Whac-a-Mole game. The goal of the Whac-a-Mole game is to& well& whack moles. With a hammer. To make the job easier you have first consulted the fortune teller and now you know the exact appearance patterns of the moles.
The moles appear out of holes occupying the n2 integer points (x,y) satisfying 0 & x, y & n in a two-dimensional coordinate system. At each time step, some moles will appear and then disappear again before the next time step. After the moles appear but before they disappear, you are able to move your hammer in a straight line to any position (x2, y2) that is at distance at most d from your current position (x1,y1). For simplicity, we assume that you can only move your hammer to a point having integer coordinates. A mole is whacked if the center of the hole it appears out of is located on the line between (x1,y1) and (x2, y2) (including the two endpoints). Every mole whacked earns you a point. When the game starts, before the first time step, you are able to place your hammer anywhere you see fit.
The input consists of several test cases. Each test case starts with a line containing three integersn, d and m, where n and d are as described above, andm is the total number of moles that will appear (1 & n & 20, 1 &d & 5, and 1 & m & 1000). Then follow m lines, each containing three integersx, y and t giving the position and time of the appearance of a mole (0 &x, y & n and 1 & t & 10). No two moles will appear at the same place at the same time.
The input is ended with a test case where n = d = m = 0. This case should not be processed.
For each test case output a single line containing a single integer, the maximum possible score achievable.
Sample Input
0 0 0Sample Output
Nordic 2006
这题我实际采用的动归方程是dp[x1][y1][x2][y2][t] = max(dp[x3][y3][x1][y1][t2] t2&t)+(x1,y1)与(x2,y2)之间的时间为t的个数;dp前面两个维度没有用,就去掉了,根据后面看只需保留他的最大值,就形成了dp[x2][y2][t]=max(dp[x1][y1][t2] t2&t)+(x1,y1)与(x2,y2)之间时间为t的个数;
注意 他能走负坐标。
在tle和wa之间不断的游荡,最后终于卡过了。
#include &iostream&
#include &algorithm&
#include &cstring&
#include &cstdio&
#include &cmath&
#define NUM 1100
#define N 33
#define M 11
int dp[N][N][M],Max[N][N][M];
int sum[N][N][N][N][M];
struct num
int x,y,t;
bool cmp(num p1,num p2)
return p1.x&p2.x;
int main()
// freopen(&data.in&,&r&,stdin);
int n,d,m;
while(scanf(&%d %d %d&,&n,&d,&m)!=EOF)
if(!n&&!m&&!d)
for(int i=1;i&=m;i++)
scanf(&%d %d %d&,&a[i].x,&a[i].y,&a[i].t);
a[i].x+=5;
a[i].y+=5;
sort(a+1,a+m+1,cmp);
for(int x1=0;x1&=n-1;x1++)
for(int y1=0;y1&=n-1;y1++)
for(int x2=0;x2&=n-1;x2++)
for(int y2=0;y2&=n-1;y2++)
for(int t=1;t&=10;t++)
sum[x1][y1][x2][y2][t]=0;
for(int x1 = 0;x1&=n-1;x1++)
for(int y1=0;y1&=n-1;y1++)
for(int x2=x1;x2&=n-1&&x2&=x1+d;x2++)
if(x2==x1)
for(;y2&=n-1&&y2&=y1+d;y2++)
if(((x2-x1)*(x2-x1)+(y2-y1)*(y2-y1))&d*d)
for(int i=1;i&=m;i++)
int x = a[i].x;
int y = a[i].y;
int t = a[i].t;
if(x1==x2&&y1==y2&&x==x1&&y==y1)
sum[x1][y1][x2][y2][t]++;
}else if(x1==x2&&y1==y2)
if(x==x1&&x==x2&&y&=y1&&y&=y2)
sum[x1][y1][x2][y2][t]++;
sum[x2][y2][x1][y1][t]++;
double k = (double)(y2-y1)/(double)(x2-x1);
double D = (double)(y2) - k *(double)(x2);
if(fabs(k*(double)(x)+D-(double)(y))&=1e-7&&x&=x1&&x&=x2)
sum[x1][y1][x2][y2][t]++;
sum[x2][y2][x1][y1][t]++;
memset(dp,0,sizeof(dp));
memset(Max,0,sizeof(Max));
for(int t=1;t&=10;t++)
for(int x1 =0;x1&=n-1;x1++)
for(int y1=0;y1&=n-1;y1++)
for(int x2=0;x2&=n-1;x2++)
for(int y2=0;y2&=n-1;y2++)
//dp[x1][y1][x2][y2][t];
if(((x2-x1)*(x2-x1)+(y2-y1)*(y2-y1))&d*d)
int mmax=0;
for(int kb=1;kb&=t-1;kb++)
mmax=max(mmax,dp[x1][y1][kb]);
Max[x2][y2][t]=max(Max[x2][y2][t],mmax+sum[x1][y1][x2][y2][t]);
for(int x2=0;x2&=n-1;x2++)
for(int y2=0;y2&=n-1;y2++)
dp[x2][y2][t] = Max[x2][y2][t];
int res = 0;
for(int i=0;i&=n-1;i++)
for(int j=0;j&=n-1;j++)
for(int t=1;t&=10;t++)
res = max(res,dp[i][j][t]);
printf(&%d\n&,res);
#include &iostream&
#include &algorithm&
#include &cstring&
#include &cstdio&
#include &cmath&
#define NUM 1100
#define N 33
#define M 11
int dp[N][N][M],Max[N][N][M];
int sum[N][N][N][N][M];
struct num
int x,y,t;
bool cmp(num p1,num p2)
return p1.x&p2.x;
int main()
// freopen(&data.in&,&r&,stdin);
int n,d,m;
while(scanf(&%d %d %d&,&n,&d,&m)!=EOF)
if(!n&&!m&&!d)
for(int i=1;i&=m;i++)
scanf(&%d %d %d&,&a[i].x,&a[i].y,&a[i].t);
a[i].x+=5;
a[i].y+=5;
sort(a+1,a+m+1,cmp);
for(int x1=0;x1&=n-1;x1++)
for(int y1=0;y1&=n-1;y1++)
for(int x2=0;x2&=n-1;x2++)
for(int y2=0;y2&=n-1;y2++)
for(int t=1;t&=10;t++)
sum[x1][y1][x2][y2][t]=0;
for(int x1 = 0;x1&=n-1;x1++)
for(int y1=0;y1&=n-1;y1++)
for(int x2=x1;x2&=n-1&&x2&=x1+d;x2++)
if(x2==x1)
for(;y2&=n-1&&y2&=y1+d;y2++)
if(((x2-x1)*(x2-x1)+(y2-y1)*(y2-y1))&d*d)
for(int i=1;i&=m;i++)
int x = a[i].x;
int y = a[i].y;
int t = a[i].t;
if(x1==x2&&y1==y2&&x==x1&&y==y1)
sum[x1][y1][x2][y2][t]++;
}else if(x1==x2&&y1==y2)
if(x==x1&&x==x2&&y&=y1&&y&=y2)
sum[x1][y1][x2][y2][t]++;
sum[x2][y2][x1][y1][t]++;
double k = (double)(y2-y1)/(double)(x2-x1);
double D = (double)(y2) - k *(double)(x2);
if(fabs(k*(double)(x)+D-(double)(y))&=1e-7&&x&=x1&&x&=x2)
sum[x1][y1][x2][y2][t]++;
sum[x2][y2][x1][y1][t]++;
memset(dp,0,sizeof(dp));
memset(Max,0,sizeof(Max));
for(int t=1;t&=10;t++)
for(int x1 =0;x1&=n-1;x1++)
for(int y1=0;y1&=n-1;y1++)
for(int x2=0;x2&=n-1;x2++)
for(int y2=0;y2&=n-1;y2++)
//dp[x1][y1][x2][y2][t];
if(((x2-x1)*(x2-x1)+(y2-y1)*(y2-y1))&d*d)
int mmax=0;
for(int kb=1;kb&=t-1;kb++)
mmax=max(mmax,dp[x1][y1][kb]);
Max[x2][y2][t]=max(Max[x2][y2][t],mmax+sum[x1][y1][x2][y2][t]);
for(int x2=0;x2&=n-1;x2++)
for(int y2=0;y2&=n-1;y2++)
dp[x2][y2][t] = Max[x2][y2][t];
int res = 0;
for(int i=0;i&=n-1;i++)
for(int j=0;j&=n-1;j++)
for(int t=1;t&=10;t++)
res = max(res,dp[i][j][t]);
printf(&%d\n&,res);
(window.slotbydup=window.slotbydup || []).push({
id: '2467140',
container: s,
size: '1000,90',
display: 'inlay-fix'
(window.slotbydup=window.slotbydup || []).push({
id: '2467141',
container: s,
size: '1000,90',
display: 'inlay-fix'
(window.slotbydup=window.slotbydup || []).push({
id: '2467142',
container: s,
size: '1000,90',
display: 'inlay-fix'
(window.slotbydup=window.slotbydup || []).push({
id: '2467143',
container: s,
size: '1000,90',
display: 'inlay-fix'
(window.slotbydup=window.slotbydup || []).push({
id: '2467148',
container: s,
size: '1000,90',
display: 'inlay-fix'}

我要回帖

更多关于 raidcooldown怎么设置 的文章

更多推荐

版权声明:文章内容来源于网络,版权归原作者所有,如有侵权请点击这里与我们联系,我们将及时删除。

点击添加站长微信